VRTX LAGs – ESXi

Setup the Out Of Band (OOB) connection on a network you can get to on the same VLAN without being routed just in case you lose access to the switch on the management VLAN.

  • Configure the hostname
    • hostname VRTX_SW
  • Configure SNTP
    • conf t
      sntp server 129.6.15.28 poll
      exit
  • Configure VLANs
    • conf t
      vlan database
      vlan 10,20-25,50,200 (examples)
      exit
  • Setup the LAG on the VRTX switch and then the switch upstream from it and test it to make sure you still have access.
    • conf t
      int range gi0/1-8
      channel-group 1 mode on
      switchport mode trunk
      exit
      exit
      interface Port-channel1
      spanning-tree portfast
      switchport mode trunk

  • Configure one of each ports assigned to each blade 1 and 2 (likely to be gi1/1 and gi2/1) to be on the same network as you intend on your ESXi install to be on, this may be on the same network as you CMC and iDracs.
  • Install ESXi and give it an IP, SM (subnet mask), GW (gateway), and DNS addresses.
  • Log into the ESXi host and go to Networking
  • Create all of the VLANs that will be used by clicking Add port group
    • Type the name like VLAN-10
    • Type the VLAN ID in this case 10
    • Click Add
  • After adding all VLANs click Virtual switches and choose vSwitch0
    • Click Edit settings
    • Choose Add uplink until all 4 vmnic’s are added (vmnic0-vmnic3)
    • Expand NIC teaming and change Load balancing to Route based on IP hash and choose Save
  • Click Networking > VMkernel NICs > Management Network
    • Click Edit settings
    • Change VLAN ID to your management VLAN ID
    • Expand NIC teaming and change Load balancing to Route based on IP hash and choose Save (if your management network is on a different VLAN you may lose access)
  • Now log back into the VRTX switch
  • Make sure that the 2 ports above (gi1/1 and gi 2/1) are removed from whatever VLAN you add to them for setup purposes
  • Now create the 2 LAGs (1 LAG for each blade)
    • conf t
      int range gi1/1-4
      channel-group 2 mode on
      switchport mode trunk
      exit
      exit
      interface Port-channel2
      spanning-tree portfast
      switchport mode trunk
      exit
      exit
    • conf t
      int range gi2/1-4
      channel-group 3 mode on
      switchport mode trunk
      exit
      exit
      interface Port-channel3
      spanning-tree portfast
      switchport mode trunk
  • Run show running-config and see if there are any leftover VLANs on the ports, no port should be tagged or untagged for 1 VLAN
  • Ping your hosts and make sure you still have access to them.

You can actually create all of the LAGs at once and just leave out one of the ports from 1/x and 2/x so those ports can be set to a trunk or untagged on the management VLAN.  This portion has been a trial and error and I usually forget one step and lose access to the servers, but with a little poking around it’s a solvable issue.  These steps should reduce that poking to a minimum or none at all.